Herramientas de usuario

Herramientas del sitio


gns3:p1

Práctica 1 con GNS3

Conectamos el router a NAT1 (fastEthernet 0/0 a nat0)

R1#configure terminalconf tEntra en el modo de configuracion del terminal
R1(config)#interface fastEhernet 0/0int f0/0Entra en la configuración del puerto f0/0
R1(config-if)#ip address dhcp Pone el puerto en modo dhcp (ip dinámica)
R1(config-if)#no shutdownno shActiva el puerto (pasa de down a up)
R1(config-if)#exit Vuelve al modo configuracion
R1(config)#exit Vuelva al modo privilegiado
R1#ping 8.8.8.8 Comprobamos si tenemos conexión a internet

Si hay conexión a internet saldrá:

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/24 ms

Terminamos el montaje:

R1#configure terminalconf tEntra en el modo de configuracion del terminal
R1(config)#interface fastEhernet 1/0int f1/0Entra en la configuración del puerto f1/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0 Pone una ip estatica
R1(config-if)#no shutdownno shActiva el puerto (pasa de down a up)
R1(config-if)#exit Vuelve al modo configuracion
R1(config)#exit Vuelva al modo privilegiado
R1#show ip interface briefsh ip int brief Vemos la configuracion de las interfaces
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        192.168.122.143 YES DHCP   up                    up
FastEthernet1/0        192.168.1.1     YES manual up                    up
FastEthernet1/1        unassigned      YES unset  administratively down down

Comprobamos la conexión a internet:

|R1#|ping 8.8.8.8| |Comprobamos si tenemos conexión a internet|

Deberá funcionar (ya comprobado anteriormente)

Configuramos el servicio dhcp en el router:

R1#configure terminalconf tEntra en el modo de configuracion del terminal
R1(config)#service dhcpser dhcp Activa el servicio dhcp
R1(config)#ip dhcp pool ELCA Creamos el pool ELCA
R1(dhcp-config)#network 192.168.1.0 255.255.255.0 Elegimos la red
R1(dhcp-config)#default-router 192.168.1.1 Ponemos el gateway
R1(dhcp-config)#dns-server 8.8.8.8 Ponemos como servidor dns el de google
R1(dhcp-config)#exit Volvemos al modo configuración
R1(config)#exit Volvemos al modo priviligiado
R1#

Nos vamos al VPCS-1. Lo arrancamos, si no lo está, y entramos en la consola:

VPCS1>ip dhcp (activamos el dhcp para que pille una ip dada por el router)

Resultado:

DDORA IP 192.168.1.2/24 GW 192.168.1.1

Probamos si tiene conexión a internet.

VPCS-1> ping 8.8.8.8

8.8.8.8 icmp_seq=1 timeout
8.8.8.8 icmp_seq=2 timeout
8.8.8.8 icmp_seq=3 timeout
8.8.8.8 icmp_seq=4 timeout
8.8.8.8 icmp_seq=5 timeout

Combrobamos que no tiene conexión a interner, pero si esta conectado al router. Hay que dar permisos en el router para permitir el tráfico (configurar la NAT).

R1#configure terminalconf tEntra en el modo de configuracion del terminal
R1(config)#interface fastEhernet 0/0int f0/0Entra en la configuración del puerto f0/0
R1(config-ip)#ip nat outside Todo el tráfico de internet saldrá por el puerto f0/0
R1(config-ip)#exit Volvemos al modo configuración
R1(config)#interface fastEhernet 1/0int f1/0Entra en la configuración del puerto f1/0
R1(config-ip)#ip nat inside Activamos el tráfico hacia dentro
R1(config-ip)#exit Volvemos al modo configuracion

En Cisco hay que activar los permisos de las ips

R1(config)#access-list 100 permit ip 192.168.1.0 0.0.0.255 any 0.0.0.255 es la inversa de la máscara de red

configuramos la NAT por sobrecarga (se utiliza mucho). Solo hay una ip pública. Todo el tráfico va hacia esa ip.

R1(config)#ip nat inside source list 100 interface f0/0 overload

Vamos al VPCS-1 y hacemos ping.

VPCS-1> ping 8.8.8.8

84 bytes from 8.8.8.8 icmp_seq=1 ttl=49 time=31.700 ms
84 bytes from 8.8.8.8 icmp_seq=2 ttl=49 time=31.121 ms
84 bytes from 8.8.8.8 icmp_seq=3 ttl=49 time=30.708 ms
84 bytes from 8.8.8.8 icmp_seq=4 ttl=49 time=30.282 ms
84 bytes from 8.8.8.8 icmp_seq=5 ttl=49 time=30.897 ms

Comprobamos que ya tiene conexión a internet.

Vamos al VPCS-2. Lo iniciamos, si esta apagado. Entramos en la consola del PC y activamos dhcp y comprobamos con ping si tenemos conexión a internet.

VPCS-2> ip dhcp

DDORA IP 192.168.1.3/24 GW 192.168.1.1

VPCS-2> ping 8.8.8.8

84 bytes from 8.8.8.8 icmp_seq=1 ttl=49 time=29.981 ms
84 bytes from 8.8.8.8 icmp_seq=2 ttl=49 time=72.504 ms
84 bytes from 8.8.8.8 icmp_seq=3 ttl=49 time=23.540 ms
84 bytes from 8.8.8.8 icmp_seq=4 ttl=49 time=29.855 ms
84 bytes from 8.8.8.8 icmp_seq=5 ttl=49 time=25.387 ms

Guardamos la configuración del router:

R1# write antiguamente era, R1#copy running-config startup-config

FIN

gns3/p1.txt · Última modificación: 2018/01/09 07:12 por carlos